Defect #19627

Cannot set task.Parent = Grandparent

Added by Ewan Makepeace over 2 years ago. Updated almost 2 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Issues
Target version:-
Resolution:Duplicate Affected version:3.0.3

Description

To reproduce:

  1. Create a task A
  2. Creata another task B and set A as parent: B -> A
  3. Create a third task C and set B as parent C -> B -> A

Suppose B and C were both supposed to be children of A:

  1. Edit C, change the parent field to refer to A instead of B
  2. Save fails.
  3. Edit C, change the parent field to nothing.
  4. Save succeeds
  5. Edit C, change the parent field to A
  6. Save succeeds

So it is only possible to make C a child of A by first removing it from B. There seems to be no justification for this?


Related issues

Duplicates Redmine - Defect #13654: Can't set parent issue when issue relations among child i... Closed

History

#1 Updated by Toshi MARUYAMA over 2 years ago

  • Affected version changed from 2.6.0 to 3.0.3

#2 Updated by Toshi MARUYAMA over 2 years ago

  • Status changed from New to Confirmed

#3 Updated by Leonel Iturralde over 2 years ago

Hi,
I think it is related to #8794 and r11641

#4 Updated by Go MAEDA almost 2 years ago

  • Status changed from Confirmed to Closed
  • Resolution set to Duplicate

Fixed by #13654.

#5 Updated by Go MAEDA almost 2 years ago

  • Duplicates Defect #13654: Can't set parent issue when issue relations among child issues are present added

Also available in: Atom PDF