Defect #19884

address column in WHERE clause is ambiguous

Added by Future Link Corporation pkgsrc team over 2 years ago. Updated over 2 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:-
Resolution:Duplicate Affected version:

Description

See: source:trunk/app/models/user.rb#L133

Easy to reproduce in 3.0.3:

  1. Commit to repo;
  2. View Repository tab in project;
  3. Application throws 500 error;

Patch attached. Note: I'm not a Ruby programmer. There might be better ways to fix this.

patch-app_models_user.rb Magnifier - patch to fix address column ambiguity in user model (465 Bytes) Future Link Corporation pkgsrc team, 2015-05-19 22:21


Related issues

Duplicates Redmine - Defect #19485: Column 'address' in where clause may be ambiguous Closed

History

#1 Updated by Toshi MARUYAMA over 2 years ago

  • Tracker changed from Patch to Defect
  • Status changed from New to Closed
  • Priority changed from High to Normal
  • Resolution set to Duplicate

Duplicate of #19485.

#2 Updated by Toshi MARUYAMA over 2 years ago

  • Category deleted (SCM)

#3 Updated by Toshi MARUYAMA over 2 years ago

  • Duplicates Defect #19485: Column 'address' in where clause may be ambiguous added

Also available in: Atom PDF