Feature #19921

Issue priority with subtasks : not with closed issues

Added by Jérôme BATAILLE over 2 years ago. Updated almost 2 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Issues
Target version:-
Resolution:Duplicate

Description

The issue priority calculation is the max of the priorities of issue and it subtasks.

It should not take in account the closed subtasks.


Related issues

Duplicates Redmine - Defect #5880: Only consider open subtasks when computing the priority o... Closed 2010-07-14

History

#1 Updated by Jérôme BATAILLE over 2 years ago

Could be implemented like this :

priority_position = p.children.joins(:priority).includes(:status).where("#{IssueStatus.table_name}.is_closed = 0").
maximum("#{IssuePriority.table_name}.position")

#2 Updated by Jérôme BATAILLE over 2 years ago

Hi, can you review this feature that is pretty straightforward ?

#3 Updated by Go MAEDA almost 2 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

Closing as a duplicate of #5880.

#4 Updated by Go MAEDA almost 2 years ago

  • Duplicates Defect #5880: Only consider open subtasks when computing the priority of a parent issue added

Also available in: Atom PDF