Feature #20405

Enable footnotes support in Markdown formatter.

Added by Mischa The Evil about 2 years ago. Updated about 2 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Text formatting
Target version:-
Resolution:Duplicate

Description

Footnotes support is not enabled for the Markdown formatter at the moment. I think it would be good if support for them is enabled. This can be done quite easily:

diff --git a/lib/redmine/wiki_formatting/markdown/formatter.rb b/lib/redmine/wiki_formatting/markdown/formatter.rb
index 17d94a1..fdf17fe 100644
--- a/lib/redmine/wiki_formatting/markdown/formatter.rb
+++ b/lib/redmine/wiki_formatting/markdown/formatter.rb
@@ -128,7 +128,8 @@ module Redmine
             :tables => true,
             :strikethrough => true,
             :superscript => true,
-            :no_intra_emphasis => true
+            :no_intra_emphasis => true,
+            :footnotes => true
           )
         end
       end

I did a quick test with footnotes support enabled and it seems to work properly OOTB. The feature with its syntax is described at the end of https://github.com/vmg/redcarpet#and-its-like-really-simple-to-use.


Related issues

Duplicates Redmine - Feature #16072: Markdown footnote support Closed

History

#1 Updated by Go MAEDA about 2 years ago

  • Status changed from New to Closed

It is interesting but duplicate of #16072.

#2 Updated by Go MAEDA about 2 years ago

#3 Updated by Go MAEDA about 2 years ago

  • Resolution set to Duplicate

#4 Updated by Mischa The Evil about 2 years ago

Go MAEDA wrote:

It is interesting but duplicate of #16072.

Thanks for catching this and transferring my textual patch. I missed that one completely.
Good to see some more eyes keeping a close sight at the issues pool :thumbsup: ;)

Also available in: Atom PDF