Feature #20603

Keep compatibility with Rails 4.1 to support SQL Server < 2012

Added by Etienne Massip about 2 years ago. Updated about 2 years ago.

Status:NewStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Rails support
Target version:-
Resolution:

Description

It would allow Redmine to be compatible with SQL Server 2005 to 2008R2 until Rails 5 makes his way out and 4.1 branch gets unmaintained.

<copy/paste from #14534#note-46 >

As Toshi noticed (Redmine 3.0 problem with MSSQL 2008) they chose to break compatibility with MSSQL < 2012 which is a bit brutal.

Specifying Rails ~> 4.1 in Gemfile seems to do the trick with trunk @ r14520, do you know if some of the changes that were made when switching from 4.1 to 4.2 aren't 4.1 compatible?

</copy/paste>

I don't think there are plans for using Rails 4.2 features, any idea?

test.log.txt Magnifier (58.5 KB) Toshi MARUYAMA, 2015-09-16 11:49

History

#1 Updated by Etienne Massip about 2 years ago

  • Description updated (diff)

#2 Updated by Toshi MARUYAMA about 2 years ago

I tried "rake test" on trunk r14589 Ruby 1.9.3 sqlite3 with this change.

diff --git a/Gemfile b/Gemfile
--- a/Gemfile
+++ b/Gemfile
@@ -4,7 +4,8 @@ if Gem::Version.new(Bundler::VERSION) <
   abort "Redmine requires Bundler 1.5.0 or higher (you're using #{Bundler::VERSION}).\nPlease update with 'gem update bundler'." 
 end

-gem "rails", "4.2.4" 
+gem "rails", "~> 4.1.13" 
+gem "loofah" 
 gem "jquery-rails", "~> 3.1.3" 
 gem "coderay", "~> 1.1.0" 
 gem "builder", ">= 3.0.4" 

I got many test failures.
How do you deal?

Also available in: Atom PDF