Defect #20900

Email not truncated when use deleted

Added by Ivan Yiu about 2 years ago. Updated about 1 month ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Accounts / authentication
Target version:-
Resolution:Invalid Affected version:

Description

I have some user deleted before. Try to create user with previously entered user's email and got the error "Email has already been taken".

Checked that the email_addresses table still have the old mail and id info. but the ID is already deleted from the users table.

History

#1 Updated by Go MAEDA about 2 years ago

  • Status changed from New to Needs feedback

I cannot reproduce it. There seems no problem in app/models/user.rb.

source:branches/3.0-stable/app/models/user.rb@14285#L85:

  has_many :email_addresses, :dependent => :delete_all

Could you please describe the procedure to reproduce?

#2 Updated by Go MAEDA about 1 month ago

  • Status changed from Needs feedback to Closed
  • Resolution set to Invalid

I am closing this issue because we have not received any feedback from the author for 2 years.

Also available in: Atom PDF