Defect #2107

Issue Filter for "Target Version" vanishes without warning when "All Projects" is checked

Added by Martin Schuster almost 9 years ago. Updated over 4 years ago.

Status:ClosedStart date:2008-10-29
Priority:LowDue date:
Assignee:-% Done:

0%

Category:Issues
Target version:-
Resolution:Duplicate Affected version:0.7.3

Description

When you create an issue filter with the parameter "Target Version" but also check "All Projects", the parameter "Target Version" silently disappears after saving the filter. Once you understand why it happens it's clear why this has to happen, but many users might consider this an error or at least won't expect it. So maybe a warning of some kind should appear or rather the checkbox "all projects" should be cleared instead of the "Target Version" parameter.


Related issues

Duplicates Redmine - Defect #1495: Queries on versions don't work globally Needs feedback 2008-06-18

History

#1 Updated by Vincent de Lau over 8 years ago

This is still an issue in 0.8.2.

There is however a valid case where the query could be saved. I wanted to create a global filter to see all issues that do not have a version assigned.

So IMHO the rule should be to allow (global) rules without a specific version number. If a specific version is specified, I would suggest to not allow it to be global.

#2 Updated by Daniel Felix over 4 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

This is a duplicate of #1495.
I'm closing this.

Also available in: Atom PDF