Defect #2123

Incoming Emails Overrides

Added by Steven Lu over 9 years ago. Updated almost 9 years ago.

Status:ClosedStart date:2008-11-01
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:-
Resolution:Cant reproduce Affected version:

Description

There is an issue when overriding the Tracker when sending an email to Redmine.

I have qmail set correctly to deliver mail to the script with tracker and status overrided.

However, when I send an email to it such as:
Project: XXXXX
Tracker: XXXXX

It will override the project but not the tracker.

History

#1 Updated by Jean-Philippe Lang over 9 years ago

I have qmail set correctly to deliver mail to the script with tracker and status overrided.

What method do you use to deliver the email to Redmine ?
Can you give your configuration/command line please ?

#2 Updated by Steven Lu over 9 years ago

I'm using it direct, here is my command line:

| /opt/redmine/extra/mail_handler/rdm-mailhandler.rb --url https://redmine.burst-dev.com --key xxxxxxxxxx --allow-override tracker,priority,status,project

I think its how it parses the email though because some lines are in the pre code.

#3 Updated by Jean-Philippe Lang over 9 years ago

Possible problems:
  • the requested tracker is not associated to your project
  • tracker name case (could be case sensitive if you use postgresql ?)

#4 Updated by Jean-Philippe Lang almost 9 years ago

  • Status changed from New to Closed
  • Resolution set to Cant reproduce

Also available in: Atom PDF