Defect #21458

LDAP account creation fails when first name/last name contain umlaut

Added by int redmine almost 2 years ago. Updated almost 2 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:LDAP
Target version:-
Resolution:Duplicate Affected version:3.2.0

Description

I get an Internal error

An error occurred on the page you were trying to access.
If you continue to experience problems please contact your Redmine administrator for assistance.
If you are the Redmine administrator, check your log files for details about the error.

during account creation on first time login by LDAP.
This is caused by umlauts (äöüß...) in first name/last name

Account creation through standard register procedure is working, when first name/last name contain umlauts.


Related issues

Duplicates Redmine - Defect #21453: LDAP account creation fails when first name/last name con... Closed

History

#1 Updated by int redmine almost 2 years ago

For addional information, I am using Active Directory as LDAP with this configuration:
Name: domain.local
Host: srv.domain.local
Port: 636 x LDAPS
Account:
Base DN: OU=Benutzer,DC=domain,DC=local
LDAP filter
(&(objectClass=user)(memberOf=cn=Mitarbeiter,cn=Users,dc=domain,dc=local))

x On-the-fly user creation
Attributes
Login attribute: sAMAccountName
Firstname attribute: givenName
Lastname attribute: sN
Email attribute: mail

#2 Updated by Toshi MARUYAMA almost 2 years ago

  • Category set to LDAP
  • Status changed from New to Closed
  • Resolution set to Duplicate

Duplicate of #21453.
Try #21453#note-4.

#3 Updated by Toshi MARUYAMA almost 2 years ago

  • Duplicates Defect #21453: LDAP account creation fails when first name/last name contain non ASCII added

Also available in: Atom PDF