Defect #21528

LDAP user autocreation doesn't work with attributes with Cyrillic

Added by Valentin Vakhrushev almost 2 years ago. Updated almost 2 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:LDAP
Target version:-
Resolution:Duplicate Affected version:3.2.0

Description

I've configured LDAP authentication in Redmine and it works fine except one thing. If some attribute in LDAP (in Active Directory in my case) consists of two or more words (contains one or more spaces) then new user from LDAP is not created. If I remove these spaces all work just fine and new user appears in Redmine.


Related issues

Duplicates Redmine - Defect #21453: LDAP account creation fails when first name/last name con... Closed

History

#1 Updated by Valentin Vakhrushev almost 2 years ago

I'm sorry guys, I was wrong. The problem is not in spaces but in number of symbols in field. In my environment the attribute named 'givenName' consists of two words: the first and the second name. And all fields contain symbols in Cyrillic (if it matters). I found that the maximum field length in my case is 15 symbols. If the field is 'longer' error occurs and user is not created.

#2 Updated by Toshi MARUYAMA almost 2 years ago

  • Subject changed from LDAP user autocreation doesn't work with attributes with spaces to LDAP user autocreation doesn't work with attributes with Cyrillic
  • Category set to LDAP
  • Status changed from New to Closed
  • Resolution set to Duplicate

Duplicate of #21453.
Try #21453#note-4.

#3 Updated by Toshi MARUYAMA almost 2 years ago

  • Duplicates Defect #21453: LDAP account creation fails when first name/last name contain non ASCII added

Also available in: Atom PDF