Feature #21549

Add the Wiki pages' hierarchy on the URL path

Added by Maxmiliano Andriani almost 2 years ago. Updated almost 2 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Wiki
Target version:-
Resolution:Duplicate

Description

I'm trying to create a fully software documentation on Redmine's Wiki, and just realised one limitation on Wiki's implementation.

It would be nice if Redmine's Wiki put on the URL the full path of a Page, something like:

/wiki/Development/Configurations/Enviroment
/wiki/Development/Configurations/Server
/wiki/Development/Standards

This feature is important because is very hard solve the name conflicts when you are creating new pages. If you want to create tow pages "Standards", one to developers and other to designers, it is not possible now. You have to hack with use of '-'

wiki/Developers/CompanyStandards
wiki/Designers/CompanyStandards
wiki/Developers-CompanyStandards
wiki/Designers-CompanyStandards

Other point is that if the url show the hierarchy, it would be easy to understand the information architecture of text.


Related issues

Duplicates Redmine - Feature #1213: Allow Slashes in wiki URLs New 2008-05-08

History

#1 Updated by Toshi MARUYAMA almost 2 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

Duplicate of #1213.

#2 Updated by Toshi MARUYAMA almost 2 years ago

Also available in: Atom PDF