Defect #2190

Month names not translated to german

Added by Martin Bächtold about 9 years ago. Updated over 5 years ago.

Status:ClosedStart date:2008-11-14
Priority:NormalDue date:
Assignee:Etienne Massip% Done:

0%

Category:I18n
Target version:2.1.0
Resolution:Fixed Affected version:

Description

You may read my comment in this issue: http://www.redmine.org/issues/2186

The month names are not displayed in german neither (december instead of Dezember).

In Settings > General, change the Date format to "14 November 2008".

Then you may visit the Roadmap-Page of a project where you must a have version defined.
In German you will see "Fällig in 47 Tagen (31 December 2008)", followed by all the tickets.
The month name is not translated, it should be Dezember.

By the way, there should be a period after the day of the month, i.e. 14. Dezember 2008.
Maybe you add this as a date format option in Settings > General.

I run Redmine 0.7.devel.2034 (MySQL)


Related issues

Related to Redmine - Patch #6729: fix regional week/month names Closed 2010-10-22
Duplicated by Redmine - Defect #4841: Error encoding Created in /admin/projects Closed 2010-02-14

Associated revisions

Revision 9838
Added by Etienne Massip over 5 years ago

Display dates using user's locale if available (#2190).

Revision 9850
Added by Toshi MARUYAMA over 5 years ago

fix unit test fails on Ruby 1.8 and JRuby (#2190)

History

#1 Updated by Azamat Hackimov about 9 years ago

Actiually, it's not bug. In Redmine settings you need set Date format to "Based user's language".

#2 Updated by Martin Bächtold about 9 years ago

Yes, this could be a solution to the problem that the month names are not displayed in the user's language.
Because when you this, then all the dates are displayed like "DD.MM.YY." so there is no month name ;-)

But what if I wanted the dates to display like "DD. Monthname YYYY"?

#3 Updated by Jean-Philippe Lang about 9 years ago

Defect confirmed. And it's not specific to german.

#4 Updated by Jean-Philippe Lang about 8 years ago

  • Category set to Translations

#5 Updated by Jean-Philippe Lang almost 7 years ago

  • Category changed from Translations to I18n

#6 Updated by Etienne Massip over 6 years ago

  • Target version set to Candidate for next major release

#7 Updated by Etienne Massip over 6 years ago

  • Target version changed from Candidate for next major release to Candidate for next minor release

#8 Updated by Etienne Massip over 5 years ago

  • Description updated (diff)

#9 Updated by Etienne Massip over 5 years ago

  • Status changed from New to Resolved
  • Target version changed from Candidate for next minor release to 2.0.3
  • Resolution set to Fixed

Fixed with r9838.

#10 Updated by Jean-Philippe Lang over 5 years ago

  • Assignee set to Etienne Massip
  • Target version changed from 2.0.3 to 2.1.0

Tests are broken with ruby1.8 and jruby and I think it can wait for 2.1.

#11 Updated by Etienne Massip over 5 years ago

Toshi fixed it with r9850, thank you very much!

String encoding in Ruby is really a PITA compared to other languages...the format I used even prevented unit tests to be run at all on JRuby.

#12 Updated by Etienne Massip over 5 years ago

  • Subject changed from Month names not translated to german? to Month names not translated to german

#13 Updated by Jean-Philippe Lang over 5 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF