Feature #21909

Issues visibility in roles: Issues where user is a watcher

Added by Emrah KAVUN over 1 year ago. Updated over 1 year ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Issues permissions
Target version:-
Resolution:Duplicate

Description

Hi there,
Currently, roles and permissions don't allow me to grant issues visibility only to issues where the user is a watcher.
This would be particularly handy in scenarios where someone else creates the issue for the user, wants to allow the user to track progress, and not expose all other project issues to the user.
The closest thing to accomplishing this today would be for the user to create the issue, and the role permission to be set to only see issues created by the user.

My clients each have their own projects and there are issues for the team, and issues for the client. I'd like to keep them separate.

Feedback welcome, and I hope this gets taken into consideration!


Related issues

Duplicates Redmine - Feature #16845: Add permission rule to allow watchers can edit issues New

History

#1 Updated by Hang Xie over 1 year ago

you can try the patch on #14318 , it works fine.

#2 Updated by Toshi MARUYAMA over 1 year ago

  • Related to Patch #14318: Watchers Alerted To Changes But Cannot See Issues (potentially) added

#3 Updated by Toshi MARUYAMA over 1 year ago

  • Related to deleted (Patch #14318: Watchers Alerted To Changes But Cannot See Issues (potentially))

#4 Updated by Toshi MARUYAMA over 1 year ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

Duplicate of #16845.

#5 Updated by Toshi MARUYAMA over 1 year ago

  • Duplicates Feature #16845: Add permission rule to allow watchers can edit issues added

Also available in: Atom PDF