Patch #2256

Allow commit messages to refer to issues in project ancestor tree, not just project

Added by Kenneth Hoxworth almost 10 years ago. Updated almost 7 years ago.

Status:ClosedStart date:2008-12-01
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:SCM
Target version:-

Description

Patch to provide functionality described in #2255. Patch is against revision 2056.

refs_in_parent_projects.patch Magnifier (1.59 KB) Kenneth Hoxworth, 2008-12-01 15:17


Related issues

Related to Redmine - Feature #2255: Repository commits in subprojects won't reference tickets... Closed 2008-12-01
Related to Redmine - Defect #6857: git references leaking from subproject to project New 2010-11-09
Related to Redmine - Feature #3687: Possibility to link all projects to a single SVN repository New 2009-07-29

History

#1 Updated by Toshi MARUYAMA over 7 years ago

  • Category set to SCM

#2 Updated by Bruno Medeiros over 7 years ago

It's already this way.

I have a project A, with repository, and projetcs A1, A2, A3... A commit on A's repo can fix an issue on any subproject.

#3 Updated by Colin Mollenhour almost 7 years ago

Bruno, a commit in A1 cannot fix an issue in A2. In my case this is a problem, mainly due to restrictions caused by the strict 1-1 relation between repos and projects. #9703 would allow for fuller control over this though.

#4 Updated by Mischa The Evil almost 7 years ago

Colin Mollenhour wrote:

Bruno, a commit in A1 cannot fix an issue in A2.

Colin, starting from Redmine 0.9.2 commits are able/allowed to reference (and fix) issues of parent projects and subprojects. Just as Bruno already said.

#5 Updated by Mischa The Evil almost 7 years ago

  • Status changed from New to Closed

Feature already implemented with r3357 for issue #4674, which was included first in Redmine 0.9.2.

Also available in: Atom PDF