Defect #22975

Moving a wiki page to a different project should refresh parent page list

Added by Karel Pičman almost 2 years ago. Updated about 1 month ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Go MAEDA% Done:

0%

Category:Wiki
Target version:4.0.0
Resolution:Fixed Affected version:

Description

When renaming a wiki page in order to move it to a different project, I change the Project in the renaming form first. But, the Parent page pick list is not updated according to the selected project. Therefore, it's not possible to set a parent from the target project and I can move it to the root only.

A wrong selection of the Parent page leads to "Parent page doesn't belong to the same project" error then.

I think that the Parent page pick list should be always filled in according to the Project selection.

wiki_renaming.png (18.6 KB) Karel Pičman, 2016-06-03 14:34

change_the_list_of_parent_pages_when_changing_project.patch Magnifier (1.77 KB) Mizuki ISHIKAWA, 2018-03-07 06:30

Associated revisions

Revision 17284
Added by Go MAEDA about 1 month ago

Moving a wiki page to a different project should refresh parent page list (#22975).

Patch by Mizuki ISHIKAWA.

History

#1 Updated by Jean-Philippe Lang almost 2 years ago

  • Tracker changed from Feature to Defect
  • Subject changed from Moving a wiki page to a different project to Moving a wiki page to a different project should refresh parent page list
  • Status changed from New to Confirmed
  • Target version set to Candidate for next minor release

#2 Updated by Mizuki ISHIKAWA 3 months ago

This problem still exists.
I wrote a patch to solve this problem.

When this patch is applied, the list of Parent Page will change according to Project change.

#3 Updated by Mischa The Evil 3 months ago

Mizuki ISHIKAWA wrote:

I wrote a patch to solve this problem.

Nice. Thanks for sharing it here. Can you add some test coverage for this?

#4 Updated by Mizuki ISHIKAWA 3 months ago

Thank you for reviewing the patch, Mischa The Evil.

Mischa The Evil wrote:

Mizuki ISHIKAWA wrote:

I wrote a patch to solve this problem.

Nice. Thanks for sharing it here. Can you add some test coverage for this?

Since there is almost no Ruby code in this patch, so I thought there was no test that could be added.
Is there a place where you can write tests from the perspective of you?

#5 Updated by Go MAEDA 3 months ago

The patch swaps the positions of "Parent page" and "Project" field. Is it necessary?

#6 Updated by Mizuki ISHIKAWA 3 months ago

Parent page will be changed by Project change.
If there is a “Parent page" above “Project” (current), I think there is a possibility that I do not notice that the list of “Parent page" has been changed.
If there is a "Parent page" is under "Project", I thought that I could perform an intuitive operation in order from top to bottom, so I changed it.

This change is not absolutely necessary.

#7 Updated by Go MAEDA 2 months ago

  • Target version changed from Candidate for next minor release to 4.0.0

Although Jean-Philippe Lang set the target version to "Candidate for next minor release", I am setting target version to 4.0.0 because the proposed patch changes the UI (swaps the positions of "Parent page" and "Project" field).

#8 Updated by Go MAEDA about 1 month ago

  • Status changed from Confirmed to Closed
  • Assignee set to Go MAEDA
  • Resolution set to Fixed

Committed. Thank you for improving Redmine.

Also available in: Atom PDF