Defect #23357

Broken links in email notification

Added by Sebastian Paluch over 1 year ago. Updated 10 months ago.

Status:Needs feedbackStart date:
Priority:HighDue date:
Assignee:-% Done:

0%

Category:Email notifications
Target version:-
Resolution: Affected version:3.3.0

Description

It seems that Redmine version 3.3.0 has broken links generation in email notifications for news (at least), with 3.2.0 noone was reporting such problem.

I have a news publish that includes following description:

New software version#1267 has been released. It is ...

{{include(myproject:100-0_Alpha_2_(rev_93029))}}

h3. Feel free to report new issues

* "myproject":/redmine/projects/myproject/issues/new
In email notification

Included wiki (myproject:100-0_Alpha_2_(rev_93029)) is in different project then the news and includes:

h3. Requirements

* Service Pack version#1272 or newer

{{include(myproject:Update_Instruction)}}

...

In email notification

Included wiki (myproject:Update_Instruction) is in different project then the news and includes:

h3. Download

All pre-production software releases are available on the "shared network location":file://host\full\path\to\directory. 

...

In email notification
  • the link to "shared network location" has been generated wrong, all "\" has been replaced with a code %5:
    file://\\host%5full%5path%5to%5directory
    the link does not work and for some reason, it is not even possible to copy it from Outlook into clipboard
Environment:
  Redmine version                3.3.0.stable
  Ruby version                   2.1.8-p440 (2015-12-16) [i386-mingw32]
  Rails version                  4.2.6
  Environment                    production
  Database adapter               Mysql2
SCM:
  Subversion                     1.8.11
  Git                            2.7.4
  Filesystem                     
Redmine plugins:
  computed_custom_field          0.0.2
  inside_avatar                  1.0.2
  issue_filters                  1.0.1
  redmine_agile                  1.4.1-3
  redmine_checklists             3.1.1-1
  redmine_custom_columns         1.1.0
  redmine_favorite_projects      2.0.2-2
  redmine_version_fixed_issues   1.0.1
  sidebar_hide                   0.0.7

History

#1 Updated by Toshi MARUYAMA over 1 year ago

  • Status changed from New to Needs feedback

#2 Updated by Sebastian Paluch over 1 year ago

Toshi MARUYAMA wrote:

Try #20192#note-4.

If I change the "Host name and path" (in application settings / General tab) to the host name only e.g. host, then all links are wrong. Correct setting is host/redmine.

Also, please note, that some links are OK, and some are NOT OK.

#3 Updated by Sebastian Paluch 10 months ago

Any chance to take a look on this?

Also available in: Atom PDF