Defect #23833

Unhandled exception on custom fields with mailto URL

Added by Jake Kemme almost 3 years ago. Updated almost 3 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Custom fields
Target version:-
Resolution:Invalid Affected version:3.3.0

Description

When attempting to create a custom field that creates a mailto: hyperlink

when clicking save:

customfielderror.png (34.5 KB) Jake Kemme, 2016-09-13 21:26

customfield.png (20 KB) Jake Kemme, 2016-09-13 21:29

mailto.png (25.7 KB) Toshi MARUYAMA, 2016-09-14 06:28

History

#1 Updated by Toshi MARUYAMA almost 3 years ago

  • File mailto.png added
  • Status changed from New to Needs feedback

I cannot reproduce.

Please see submissions.

#2 Updated by Jake Kemme almost 3 years ago

The unhandled exception was due to a bug in ruby 2.2 in versions < 2.2.5 p284 (Issue 10738) The unhandled part was resolved by updating ruby to the latest 2.2.5 patch.

However, ruby URI.parse does not consider mailto: addresses invalid. The bug is that mailto:%value% is not in the form mailto: (a valid email address). However, there is no other option to display clickable email addresses as a custom field. The validation here on the URL field should not apply, due to value being valid replacement syntax.

#3 Updated by Toshi MARUYAMA almost 3 years ago

  • Status changed from Needs feedback to Closed
  • Resolution set to Invalid

Jake Kemme wrote:

The unhandled exception was due to a bug in ruby 2.2 in versions < 2.2.5 p284 (Issue 10738) The unhandled part was resolved by updating ruby to the latest 2.2.5 patch.

Thank you for your feedback.

However, ruby URI.parse does not consider mailto: addresses invalid. The bug is that mailto:%value% is not in the form mailto: (a valid email address). However, there is no other option to display clickable email addresses as a custom field. The validation here on the URL field should not apply, due to value being valid replacement syntax.

Please create new issue.

Also available in: Atom PDF