Defect #23942

Test: Mysql2::Error: Deadlock found when trying to get lock

Added by Stefan Rinkes over 2 years ago. Updated over 2 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Database
Target version:-
Resolution:Duplicate Affected version:3.3.0

Description

This Unit Test is always failing in my setup with MySQL.
All other Tests run with rake test are fine.

ruby test/unit/issue_nested_set_concurrency_test.rb
/var/lib/gems/2.3.0/gems/htmlentities-4.3.1/lib/htmlentities/mappings/expanded.rb:465: warning: key "inodot" is duplicated and overwritten on line 466
Run options: --seed 18494

# Running:

FF

Finished in 2.488381s, 0.8037 runs/s, 1.6075 assertions/s.

  1) Failure:
IssueNestedSetConcurrencyTest#test_concurrency [test/unit/issue_nested_set_concurrency_test.rb:45]:
Expected "Mysql2::Error: Deadlock found when trying to get lock; try restarting transaction: SELECT `issues`.`id` FROM `issues` WHERE (root_id IN (SELECT root_id FROM issues WHERE id IN (225)))  ORDER BY `issues`.`id` ASC FOR UPDATE" to be nil.

  2) Failure:
IssueNestedSetConcurrencyTest#test_concurrent_subtasks_creation [test/unit/issue_nested_set_concurrency_test.rb:61]:
Expected "Mysql2::Error: Deadlock found when trying to get lock; try restarting transaction: SELECT `issues`.`id` FROM `issues` WHERE (root_id IN (SELECT root_id FROM issues WHERE id IN (229)))  ORDER BY `issues`.`id` ASC FOR UPDATE" to be nil.

2 runs, 4 assertions, 2 failures, 0 errors, 0 skips

Related issues

Duplicates Redmine - Defect #19344: MySQL 5.6: IssueNestedSetConcurrencyTest#test_concurrency... New

History

#1 Updated by Toshi MARUYAMA over 2 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

Duplicate of #19344.

#2 Updated by Toshi MARUYAMA over 2 years ago

  • Duplicates Defect #19344: MySQL 5.6: IssueNestedSetConcurrencyTest#test_concurrency : always fails added

Also available in: Atom PDF