Defect #24648

Time shown in PDF or CSV export is different than the time shown in the issue list (when logged in both parents and children)

Added by Olivier Houdas over 1 year ago. Updated over 1 year ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:PDF export
Target version:-
Resolution:Invalid Affected version:3.3.1

Description

Steps to repro:
1. Take a task with at least one child
2. Log time for both the parent and the child
3. Display that task with the Spent time column active, in a list of issues
4. Export that list to CSV or PDF
Result:
  • at step 3, we see the total logged time in the Spent time column
  • at step 4, we see only children tasks' logged time in the spent column

24648-screenshot.png (24.1 KB) Go MAEDA, 2017-01-02 13:42

History

#1 Updated by Go MAEDA over 1 year ago

I cannot reproduce. It looks no problem for me.
Could you describe more detail according to Submissions?

#2 Updated by Olivier Houdas over 1 year ago

Sorry, my fault. I had in fact introduced that bug myself by mixing spent_hours and total_spent_hours in the patch suggestion for #24649.

#3 Updated by Go MAEDA over 1 year ago

  • Status changed from Needs feedback to Closed
  • Resolution set to Invalid

Thank you for the feedback.
Closing.

Also available in: Atom PDF