Feature #24806

Possibility to hide Issue History from a role

Added by Arnaud Pissot 11 months ago. Updated 11 months ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Issues permissions
Target version:-
Resolution:Duplicate

Description

Hello,

In my company we have a Redmine shared with some partners, we are working on projects with them to implement some features on our products for specific customers, etc.
We discuss with our partners in the History of the issue by adding notes and they respond.

Actually we want to give access (in restricted view, no edit) to our customers their projects but we don't want customers to see the discussion with our partner, so disable the Issue history for them.

Is it possible by any way to do it ?
I think it would be great to implement this in the "Roles and permissions" as there is already an option for hiding Wiki History to a role like in the screenshot attached.

Thanks !

Issue permission - History.png (82.6 KB) Arnaud Pissot, 2017-01-11 09:46


Related issues

Duplicates Redmine - Feature #12089: Hide Issue History New

History

#1 Updated by Arnaud Pissot 11 months ago

I would like to add that our partners don't know that much Redmine and always forget to set notes as private.

#2 Updated by Go MAEDA 11 months ago

#3 Updated by Go MAEDA 11 months ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

Not implemented yet but closing as a duplicate of #12089.
Thank you for submitting this issue.

Also available in: Atom PDF