Feature #25224

rubygem install error...

Added by simon kong 8 months ago. Updated 8 months ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:-
Resolution:Invalid

Description

Hi,dear,
My Environment:
OS:centos 7 server 64bit
ruby: ruby 2.0.0p648 (2015-12-16) [x86_64-linux]

When I install the rubygem , sth wrong occured, though I've tried several different version:

#*ruby setup.rb* 
RubyGems 2.2.5 installed
/home/kserver/Downloads/rubygems-2.2/lib/rubygems/core_ext/kernel_require.rb:55:in `require': cannot load such file -- json/pure (LoadError)
    from /home/kserver/Downloads/rubygems-2.2/lib/rubygems/core_ext/kernel_require.rb:55:in `require'
    from /usr/share/gems/gems/json-1.7.7/lib/json.rb:60:in `rescue in <module:JSON>'
    from /usr/share/gems/gems/json-1.7.7/lib/json.rb:57:in `<module:JSON>'
    from /usr/share/gems/gems/json-1.7.7/lib/json.rb:54:in `<top (required)>'
    from /home/kserver/Downloads/rubygems-2.2/lib/rubygems/core_ext/kernel_require.rb:55:in `require'
    from /home/kserver/Downloads/rubygems-2.2/lib/rubygems/core_ext/kernel_require.rb:55:in `require'
    from /usr/share/gems/gems/rdoc-4.0.0/lib/rdoc/text.rb:16:in `<top (required)>'
    from /usr/share/gems/gems/rdoc-4.0.0/lib/rdoc/code_object.rb:28:in `<class:CodeObject>'
    from /usr/share/gems/gems/rdoc-4.0.0/lib/rdoc/code_object.rb:26:in `<top (required)>'
    from /usr/share/gems/gems/rdoc-4.0.0/lib/rdoc/generator/markup.rb:59:in `<top (required)>'
    from /home/kserver/Downloads/rubygems-2.2/lib/rubygems/core_ext/kernel_require.rb:55:in `require'
    from /home/kserver/Downloads/rubygems-2.2/lib/rubygems/core_ext/kernel_require.rb:55:in `require'
    from /usr/share/gems/gems/rdoc-4.0.0/lib/rdoc/generator/darkfish.rb:6:in `<top (required)>'
    from /home/kserver/Downloads/rubygems-2.2/lib/rubygems/core_ext/kernel_require.rb:55:in `require'
    from /home/kserver/Downloads/rubygems-2.2/lib/rubygems/core_ext/kernel_require.rb:55:in `require'
    from /usr/share/gems/gems/rdoc-4.0.0/lib/rdoc/rdoc.rb:563:in `<top (required)>'
    from /home/kserver/Downloads/rubygems-2.2/lib/rubygems/core_ext/kernel_require.rb:55:in `require'
    from /home/kserver/Downloads/rubygems-2.2/lib/rubygems/core_ext/kernel_require.rb:55:in `require'
    from /usr/share/gems/gems/rdoc-4.0.0/lib/rdoc/rubygems_hook.rb:64:in `load_rdoc'
    from /usr/share/gems/gems/rdoc-4.0.0/lib/rdoc/rubygems_hook.rb:229:in `setup'
    from /usr/share/gems/gems/rdoc-4.0.0/lib/rdoc/rubygems_hook.rb:142:in `generate'
    from /home/kserver/Downloads/rubygems-2.2/lib/rubygems/commands/setup_command.rb:317:in `install_rdoc'
    from /home/kserver/Downloads/rubygems-2.2/lib/rubygems/commands/setup_command.rb:148:in `execute'
    from /home/kserver/Downloads/rubygems-2.2/lib/rubygems/command.rb:305:in `invoke_with_build_args'
    from /home/kserver/Downloads/rubygems-2.2/lib/rubygems/command_manager.rb:167:in `process_args'
    from /home/kserver/Downloads/rubygems-2.2/lib/rubygems/command_manager.rb:137:in `run'
    from /home/kserver/Downloads/rubygems-2.2/lib/rubygems/gem_runner.rb:54:in `run'
    from setup.rb:45:in `<main>'

History

#1 Updated by Toshi MARUYAMA 8 months ago

  • Category deleted (Gems support)
  • Status changed from New to Closed
  • Priority changed from Urgent to Normal
  • Resolution set to Invalid

Please use forum for question.

Also available in: Atom PDF