Defect #25959

"Smile of the death" problem

Added by Maxim Krušina 5 months ago. Updated 5 months ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:-
Resolution:Invalid Affected version:3.3.1

Description

Hi, just pasted this string into Ticket description (or comment) and it will crash Redmine:
A druhá věc, možná bych ten pruh dole, světle modrou, vyměnil za naší tmavě modrou

1.png (41.7 KB) Toshi MARUYAMA, 2017-05-17 14:33

python.png (11.4 KB) Toshi MARUYAMA, 2017-05-17 18:08

History

#1 Updated by Maxim Krušina 5 months ago

  • Affected version changed from 3.2.5 to 3.3.1

Hmm, THIS instance will not crash, but there is no smile. Our instance will crash.

Whole string including smile is here:
https://docs.google.com/document/d/1lxVicYv_DMSgJmqGOeClgY1pbdfXqh_Nf6jiIZoOpug/edit

#2 Updated by Toshi MARUYAMA 5 months ago

  • File 1.png added
  • Status changed from New to Closed
  • Resolution set to Cant reproduce

#3 Updated by Vasili Korol 5 months ago

I can reproduce the problem. "Internal server error" appears after attempting to create a ticket with the following string in the title and description (copied together with the smiley from the google document in comment 1:

A druhá věc, možná bych ten pruh dole, světle modrou, vyměnil za naší tmavě modrou

My version of Redmine:

Environment:
  Redmine version                3.2.4.stable
  Ruby version                   2.0.0-p384 (2014-01-12) [x86_64-linux-gnu]
  Rails version                  4.2.7.1
  Environment                    production
  Database adapter               Mysql2
SCM:
  Subversion                     1.8.8
  Git                            1.9.1
  Filesystem                     
Redmine plugins:
  advanced_roadmap_v2            2.4.2

#4 Updated by Marius BALTEANU 5 months ago

The are multiple issue reported on the same subject, please see #21398, #18866 and #19742.

We had the same issue and we fixed it by migrating our Mysql database to utf8mb4. I think that the installation doc from RedmineInstall could be improved and include this change.

#5 Updated by Vasili Korol 5 months ago

Update: the smiley in my previous comment was first visible, but now it disappeared.

#6 Updated by Toshi MARUYAMA 5 months ago

  • File python.png added
  • Resolution changed from Cant reproduce to Invalid

This is FAQ.

#7 Updated by Toshi MARUYAMA 5 months ago

  • Category deleted (Issues)

Also available in: Atom PDF