Defect #26148

Cannot import custom fields with multiple values in 3.3

Added by kay_chen kay 4 months ago. Updated 3 months ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Importers
Target version:-
Resolution:Wont fix Affected version:

Description

hi,

I use the Redmine v3.3 import fucntion , the Custom field(List) value can not be set.

Seems to support only Text format ???

My inistall information

Environment:
Redmine version 3.3.3.stable.16662
Ruby version 2.2.7-p470 (2017-03-28) [x86_64-linux]
Rails version 4.2.7.1
Environment production
Database adapter Mysql2
SCM:
Subversion 1.9.3
Git 2.13.0


Related issues

Related to Redmine - Feature #16549: Set multiple values in emails for list custom fields Closed

Associated revisions

Revision 16834
Added by Jean-Philippe Lang 3 months ago

Adds a test for importing list custom fields (#26148).

Revision 16837
Added by Jean-Philippe Lang 3 months ago

Adds a test for importing list custom fields with multiple values (#26148).

History

#1 Updated by Mischa The Evil 4 months ago

  • Status changed from New to Needs feedback
  • Resolution set to Cant reproduce

I can't reproduce the issue with the current amount of information. Setting custom field values for custom fields of types other than text (eg. list) during issue CSV import is supported and working (just tested it on a vanilla source:/trunk@16643 with a list type custom field).

#2 Updated by kay_chen kay 3 months ago

I use v3.3.3 is not work,can you give me a csv example ? (I test is the first export csv and then import)

#3 Updated by Toshi MARUYAMA 3 months ago

  • Resolution deleted (Cant reproduce)

I can confirm Redmine 3.3 cannot import list custom fields.
I can confirm Redmine 3.4 can import list custom fields.
It seems #16549 fixed it.

#4 Updated by Toshi MARUYAMA 3 months ago

  • Related to Feature #16549: Set multiple values in emails for list custom fields added

#5 Updated by Toshi MARUYAMA 3 months ago

  • Subject changed from Redmine v3.3 import fucntion , Custom field only support Text format ? to v3.3 cannot import list custom fields

#6 Updated by Toshi MARUYAMA 3 months ago

  • Tracker changed from Feature to Defect

#7 Updated by Mischa The Evil 3 months ago

  • Status changed from Needs feedback to Confirmed

#8 Updated by Jean-Philippe Lang 3 months ago

I've committed a test for importing issues with a list custom field (r16834).
It passes on both trunk and 3.3-stable. I've also tested it manually on 3.3-stable, it works. Could someone provide more detailed information to reproduce this issue?

#9 Updated by Toshi MARUYAMA 3 months ago

Redmine 3.3 cannot import multi items.

#,Subject,cf_issue_list_01
,test1,a
,test2,"a, b" 
  • test1: a -> a
  • test2: "a, b" -> ""

#10 Updated by Jean-Philippe Lang 3 months ago

  • Subject changed from v3.3 cannot import list custom fields to Cannot import list custom fields with multiple values in 3.3
  • Status changed from Confirmed to Closed

It was indeed implemented as part of #16549 for 3.4.
This is not a simple fix, it won't be merged into 3.3.

#11 Updated by Jean-Philippe Lang 3 months ago

  • Subject changed from Cannot import list custom fields with multiple values in 3.3 to Cannot import custom fields with multiple values in 3.3

#12 Updated by Go MAEDA 3 months ago

  • Resolution set to Wont fix

Also available in: Atom PDF