Defect #26608

Assign Role to a Custom Query fires an error-message

Added by Klemens Rosenberg 3 months ago. Updated 3 months ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Issues
Target version:-
Resolution:Duplicate Affected version:3.1.0

Description

Error store Custom Query
On creating custom issue-queries it is possible to assign a role to permit access to that query to users of that role.
But saving that query failes because selected roles are cleared on saving-process. Following effect is occuring an errormessage that roles has to be selected - but they were selected.
Reproduce as:
  • Create a custom query
  • Select for visibility: Only for these roles and select effected roles
  • Press save-button
  • Error occures: "Roles has to be selected"

Related issues

Duplicates Redmine - Defect #20427: Cannot create a custom query visibility is "to these role... Closed

History

#1 Updated by Go MAEDA 3 months ago

  • Duplicates Defect #20427: Cannot create a custom query visibility is "to these roles only" added

#2 Updated by Go MAEDA 3 months ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

Fixed in Redmine 3.1.1 and 3.0.5 (#20427).
Please update your Redmine instance.

Also available in: Atom PDF