Defect #27229

public_suffix requires Ruby version >= 2.0

Added by Pavel Potcheptsov about 1 year ago. Updated about 1 year ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Gems support
Target version:-
Resolution:Fixed Affected version:3.4.3

Description

There is table which states that ruby 1.9.3 is compatible with redmine 3.4.
However 3.4.3 has in Gemfile:

gem "public_suffix", "~> 2.0.5" if RUBY_VERSION < "2.1" 

But
gem install public_suffix -v '2.0.5'
ERROR:  Error installing public_suffix:
        public_suffix requires Ruby version >= 2.0.

So 3.4.3 is no longer works with Ruby 1.9.3 or is it possible to use older version of this gem with support of Ruby 1.9.3?


Related issues

Related to Redmine - Defect #27206: Cannot install public_suffix if ruby < 2.1 Closed

Associated revisions

Revision 17014
Added by Toshi MARUYAMA about 1 year ago

3.4-stable: Gemfile: pin public_suffix if ruby < 2.0 (#27229)

Revision 17015
Added by Toshi MARUYAMA about 1 year ago

3.3-stable: Gemfile: pin public_suffix if ruby < 2.0 (#27229)

Revision 17016
Added by Toshi MARUYAMA about 1 year ago

3.2-stable: Gemfile: pin public_suffix if ruby < 2.0 (#27229)

History

#1 Updated by Go MAEDA about 1 year ago

  • Related to Defect #27206: Cannot install public_suffix if ruby < 2.1 added

#2 Updated by Toshi MARUYAMA about 1 year ago

  • Status changed from New to Closed
  • Resolution set to Fixed

I recommend you not use ruby 1.9.3.

Also available in: Atom PDF