Defect #27361

Failed when using Emoji

Added by Charles So almost 2 years ago. Updated 3 months ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Database
Target version:-
Resolution:Duplicate Affected version:3.0.4

Description

Tried to create Issue directly or via email with emoji, reply to forum via email using emoji, and all failed.

Here is output from Production.log

ActiveRecord::StatementInvalid (Mysql2::Error: Incorrect string value: '\xF0\x9F\x87\xA6\xF0\x9F...' for column 'description' at row 1: INSERT INTO `issues` (`project_id`, `author_id`, `priority_id`, `tracker_id`, `status_id`, `subject`, `description`, `start_date`, `updated_on`, `created_on`, `lock_version`) VALUES (33, 4, 4, 2, 1, 'CCCCC list', '-

Screen Shot 2017-11-02 at 11.40.11 AM.jpg (76.1 KB) Charles So, 2017-11-02 04:41


Related issues

Related to Redmine - Feature #31921: Changes to properly support 4 byte characters (emoji) whe... Closed
Duplicates Redmine - Defect #24992: MailHandler: an unexpected error occurred when receiving ... Needs feedback

History

#1 Updated by Charles So almost 2 years ago

The error log above originally contains a few emojis.... and the whole string got cut off immediately at where the 1st emoji is.

#2 Updated by Charles So almost 2 years ago

Here is a screen capture of the Production.log

#3 Updated by Toshi MARUYAMA almost 2 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

Duplicate of #24992.

#4 Updated by Toshi MARUYAMA almost 2 years ago

  • Duplicates Defect #24992: MailHandler: an unexpected error occurred when receiving email: invalid byte sequence in UTF-8 added

#6 Updated by Tobias Fischer 3 months ago

Related issue in Git commits: #24030

#7 Updated by Tobias Fischer 3 months ago

Related with more discussion: #18866 and #21398

#8 Updated by Marius BALTEANU about 1 month ago

  • Related to Feature #31921: Changes to properly support 4 byte characters (emoji) when database is MySQL added

Also available in: Atom PDF