Feature #27401

Switch from View ticket to Edit Ticket - hit the button E on your keyboard

Added by Ralf Roeber 13 days ago. Updated 12 days ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:UI
Target version:-
Resolution:Duplicate

Description

Coming from Confluence I really love that "E" button on my keyboard.
Whenever I hit redmine and try to edit a ticket, pressing the "E" key makes me wonder, why Redmine not offers this handy, candy key to open the edit view of the ticket.
.
Pls add a keylistener to ticket view switching from VIEW to EDIT, when hitting "E" on the keyboard.
.
Would love to support you, testing the feature.
.
Thanks for taking my humble thoughts into consideration.


Related issues

Duplicates Redmine - Feature #449: Keyboard shortcuts Reopened
Duplicates Redmine - Feature #6846: Add VIM-like keyboard shortcuts New 2010-11-08

History

#1 Updated by Mischa The Evil 13 days ago

  • Status changed from New to Needs feedback

Redmine already provides the edit ('e') accesskey on the issue show view (among others). Using for example Chrome on Windows 10, you'd use 'shift + alt + e' to edit an issue (or a document, news, wiki page) from its respective show view.

#2 Updated by Ralf Roeber 12 days ago

Hi Mischa,

thanks for your fast feedback.

shift+alt+E != e
I find hitting just "e" much more intuitive.

If this does not persuade you, just close the ticket.

best regards,
Ralf

#3 Updated by Mischa The Evil 12 days ago

#4 Updated by Mischa The Evil 12 days ago

  • Duplicates Feature #6846: Add VIM-like keyboard shortcuts added

#5 Updated by Mischa The Evil 12 days ago

  • Status changed from Needs feedback to Closed
  • Resolution set to Duplicate

Ralf Roeber wrote:

I find hitting just "e" much more intuitive.

I understand and agree, but that is just how it currently is. The current implementation of access keys depends on HTML accesskey attributes which won't let you bind to just 'e'.
Alternatively, this can be accomplished by utilizing JavaScript-based shortcuts that do not require the use of Ctrl/Alt/Shift keys like regular HTML access keys do. This is something beyond the scope of your request and is already being tracked via issue #6846 (and implemented by the redmine_keyboard_shortcuts plugin).

If this does not persuade you, just close the ticket.

This is not a matter of persuasion, just of the facts mentioned above :). Closing as a duplicate of #449 and #6846.

Also available in: Atom PDF