Defect #27975

CSV export of different language

Added by Alexander Shirobokov over 1 year ago. Updated over 1 year ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:-
Resolution:Duplicate Affected version:

Description

Default language was Russian (Cyrillic). And all issues written in Cyrillic. Export issues to csv was fine.
When we change default language to English, all our issues export as "???????".
"???????" in all encoding.

Open dialog of libreoffice to import csv:

Environment:
Redmine version 3.4.2.stable
Ruby version 2.3.0-p0 (2015-12-25) [x86_64-linux]
Rails version 4.2.8
Environment production
Database adapter Mysql2

cyrillic.png (31.3 KB) Alexander Shirobokov, 2018-01-12 11:06


Related issues

Related to Redmine - Feature #26279: Allow switching the encoding to UTF-8 when exporting to CSV Closed

History

#1 Updated by Toshi MARUYAMA over 1 year ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

Duplicate of #27213 and many others.

#2 Updated by Go MAEDA over 1 year ago

This issue will be addressed if the patch submitted in #26279 is merged. It implements a feature to switch encoding to UTF-8 when export issues to CSV.

#3 Updated by Go MAEDA over 1 year ago

  • Related to Feature #26279: Allow switching the encoding to UTF-8 when exporting to CSV added

Also available in: Atom PDF