Defect #28035

Order of versions is not correctly ordered

Added by Robert Schneider over 1 year ago. Updated about 1 month ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:-
Resolution:Duplicate Affected version:

Description

I see this with version 3.4.2 and on redmine.org at different places:

  • in project configuration
  • in custom field
  • in Roadmap: completed versions in sidebar or when all gets shown
  • in issue list filter for version custom field

Which kind of sorting is it currently? It is not the id and it doesn't seem to be the name.


Related issues

Duplicates Redmine - Feature #6881: Version numbering sort New 2010-11-13

History

#1 Updated by Toshi MARUYAMA over 1 year ago

  • Status changed from New to Closed

source:tags/3.4.4/app/models/version.rb#L197

Versions are sorted by effective_date and name
Those with no effective_date are at the end, sorted by name

in issue list filter for version custom field

Please explain more details.
redmine.org is not recent version.

#2 Updated by Toshi MARUYAMA over 1 year ago

  • Status changed from Closed to New

#3 Updated by Toshi MARUYAMA over 1 year ago

  • Status changed from New to Needs feedback

#4 Updated by Robert Schneider over 1 year ago

Okay, I see. Doesn't look natural to me, but that's just my opinion.

I would prefer a an order independent of the effective date. Ideally, if the version has a format x.y.z it should be:

1.1.1
1.1.2
1.1.10
1.2.0
1.3.0
1.20.0

#5 Updated by Go MAEDA 4 months ago

#6 Updated by Go MAEDA 4 months ago

  • Status changed from Needs feedback to Closed
  • Resolution set to Duplicate

Closing as a duplicate of #6881.

#7 Updated by Edgars Batna about 1 month ago

Versions should be sorted by version. Sorting that runs on invisible criteria is bogus.

Also available in: Atom PDF