Defect #28951

Cannot clear category field on copying an Issue

Added by László Végh about 1 month ago. Updated about 1 month ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Jean-Philippe Lang% Done:

0%

Category:Issues
Target version:4.0.0
Resolution:Fixed Affected version:

Description

If I copy an issue with a non-empty category and clear the category field, the category is still set in the new (copied) issue.

Environment:
  Redmine version                3.4.5.stable
  Ruby version                   2.3.7-p456 (2018-03-28) [x86_64-linux]
  Rails version                  4.2.8
  Environment                    production
  Database adapter               Mysql2
SCM:
  Git                            2.14.1
  Filesystem                     
Redmine plugins:
  redmine_agile                  1.4.6
DB:
  mysql 5.6.39

Related issues

Related to Redmine - Feature #15919: Set default category assignee immediately upon category s... Reopened

Associated revisions

Revision 17395
Added by Jean-Philippe Lang about 1 month ago

Cannot clear category field on copying an Issue (#28951).

History

#1 Updated by László Végh about 1 month ago

This was working before the upgrade (3.1.0 -> 3.4.5)

#2 Updated by Go MAEDA about 1 month ago

  • Status changed from New to Confirmed
  • Target version set to 4.0.0
  • Affected version deleted (3.4.5)

Confirmed the problem. This is due to r17320. The trunk is affected but stable branches are not.

#3 Updated by Go MAEDA about 1 month ago

  • Related to Feature #15919: Set default category assignee immediately upon category selection added

#4 Updated by Jean-Philippe Lang about 1 month ago

Go MAEDA wrote:

Confirmed the problem. This is due to r17320. The trunk is affected but stable branches are not.

This problem should be fixed by r17395.
But the OP is using a stable branch, can you confirm?

#5 Updated by Go MAEDA about 1 month ago

  • Assignee set to Jean-Philippe Lang

Jean-Philippe Lang wrote:

But the OP is using a stable branch, can you confirm?

No, I cannot reproduce it on 3.4.6. Probably the reporter is using the master branch of https://github.com/redmine/redmine. It is not an svn working copy, so Redmine does not add ".devel.nnnnn" information to the version number.

I think we can close this issue.

#6 Updated by Jean-Philippe Lang about 1 month ago

  • Status changed from Confirmed to Closed
  • Resolution set to Fixed

Also available in: Atom PDF