Patch #29160

Remove unused and broken method CustomField.visibility_condition

Added by Holger Just 3 months ago. Updated 2 days ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Jean-Philippe Lang% Done:

0%

Category:Code cleanup/refactoring
Target version:4.0.0

Description

The class method was introduced in r12012 along with the instance method CustomField#visibility_by_project_condition. The method's body seems to follow the idea of the instance method but misses a lot of data required by it, including the user and the project_key. As such, the method would always throw an exception when called.

Since the method is not tested, is never called by Redmine anywhere, and is unusable anyway, we can simply remove it as done by the attached patch.

0001-Remove-unused-and-broken-method-CustomField.visibili.patch Magnifier (1.11 KB) Holger Just, 2018-06-29 14:47


Related issues

Related to Redmine - Feature #5037: Role-based issue custom field visibility Closed 2010-03-10

Associated revisions

Revision 17507
Added by Jean-Philippe Lang 2 days ago

Remove unused and broken method CustomField.visibility_condition (#29160).

Patch by Holger Just.

History

#1 Updated by Go MAEDA 3 months ago

  • Related to Feature #5037: Role-based issue custom field visibility added

#2 Updated by Go MAEDA 3 months ago

  • Target version changed from Candidate for next minor release to 4.0.0

I have confirmed the problem Holger reported. Setting target version to 4.0.0.

#3 Updated by Jean-Philippe Lang 2 days ago

  • Status changed from New to Closed
  • Assignee set to Jean-Philippe Lang

Committed, thanks.

Also available in: Atom PDF