Patch #29289

Wrap subprojects in the overview section with an unordered list to improve customisation

Added by Bernhard Rohloff about 1 year ago. Updated 6 months ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Go MAEDA% Done:

0%

Category:UI
Target version:4.1.0

Description

The proposed patches wrap the subprojects inside an unordered list but preserves the original view.
The intention behind this proposal is to give users and theme designers more freedom in styling the subprojects section in the project overview without the need of patching it.

reattach_old_style_to_new_list.diff Magnifier (675 Bytes) Bernhard Rohloff, 2018-07-29 13:41

change_view_to_unordered_list.diff Magnifier (684 Bytes) Bernhard Rohloff, 2018-07-29 13:41

29289-overflow@2x.png (12.6 KB) Go MAEDA, 2018-11-05 11:06

reattach_old_style_to_new_list_v2.diff Magnifier (684 Bytes) Bernhard Rohloff, 2018-11-05 13:57


Related issues

Related to Redmine - Patch #8383: Display subprojects as individual unordered list items on... New 2011-05-17

Associated revisions

Revision 18077
Added by Go MAEDA 6 months ago

Wrap subprojects in the overview section with an unordered list (#29289).

Patch by Bernhard Rohloff.

History

#1 Updated by Go MAEDA about 1 year ago

  • Related to Patch #8383: Display subprojects as individual unordered list items on project overview added

#2 Updated by Go MAEDA about 1 year ago

  • Target version set to Candidate for next major release

#3 Updated by Go MAEDA about 1 year ago

  • Target version changed from Candidate for next major release to 4.1.0

#4 Updated by Go MAEDA 12 months ago

Project names overflow the box after applying the patches. Could you investigate it?

#5 Updated by Bernhard Rohloff 12 months ago

@Go MAEDA Thank you for pointing it out.
I've attached a new version of the stylesheet patch which fix the problem.

#6 Updated by Go MAEDA 12 months ago

Bernhard Rohloff wrote:

I've attached a new version of the stylesheet patch which fix the problem.

I confirmed that the problem was fixed now. Thank you for updating the patch so quickly.

#7 Updated by Go MAEDA 6 months ago

  • Subject changed from Wrap subprojects in the overview section with an unordered list to improve customisation. to Wrap subprojects in the overview section with an unordered list to improve customisation
  • Status changed from New to Closed
  • Assignee set to Go MAEDA

Committed the patch. Thank you.

Also available in: Atom PDF