Defect #29454

Error 500 while creating new issue

Added by Eric Perdigau about 1 year ago. Updated about 1 month ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Issues
Target version:-
Resolution:No feedback Affected version:3.0.3

Description

Hi,

I'm sorry to ask for some help but it is quite strange. Today creating new issue get an error 500. Updating issue is working correctly ...

Here is the final line of production.log

Processing by IssuesController#create as HTML
  Parameters: {"utf8"=>"✓", "authenticity_token"=>"fi3vATpXgOHqN9DOVEk4CJWrRFBvtKHHPjj1LZLE/2iOtDmD3LOrKbpscYW4x5KslxDYsOyx0yIecSg9e6xYbw==", "form_update_triggered_by"=>"", "issue"=>{"is_private"=>"0", "tracker_id"=>"7", "subject"=>"test", "description"=>"", "status_id"=>"1", "priority_id"=>"2", "assigned_to_id"=>"", "parent_issue_id"=>"", "start_date"=>"2018-08-29", "due_date"=>"", "estimated_hours"=>"", "done_ratio"=>"0", "deals_issue_attributes"=>{"deal_id"=>""}}, "was_default_status"=>"1", "commit"=>"Créer", "project_id"=>"commercial-eric-perdigau"}
  Current user: eric (id=18)
Completed 500 Internal Server Error in 61ms (ActiveRecord: 12.7ms)

NoMethodError (undefined method `after_create' for nil:NilClass):
  app/models/issue.rb:210:in `create_or_update'
  app/controllers/issues_controller.rb:140:in `create'
  lib/redmine/sudo_mode.rb:63:in `sudo_mode'

And here the environment

Environment:
  Redmine version                3.3.1.stable
  Ruby version                   2.2.1-p85 (2015-02-26) [x86_64-linux]
  Rails version                  4.2.7.1
  Environment                    production
  Database adapter               Mysql2
SCM:
  Subversion                     1.6.17
  Git                            1.7.10.4
  Filesystem                     
Redmine plugins:
  redmine_agile                  1.4.1
  redmine_checklists             3.1.5
  redmine_ckeditor               1.1.4
  redmine_contacts               4.0.5
  redmine_contacts_invoices      4.1.2
  redmine_favorite_projects      2.0.3
  redmine_knowledgebase          3.2.1
  redmine_people                 1.2.0
  redmine_products               2.0.2
  redminecrm_custom_improvements 1.0.9

If somebody has a clue it would be great, everything was working fine yesterday, and today not, i tried to find without success

Thanks a lot

History

#1 Updated by Go MAEDA about 1 year ago

  • Status changed from New to Needs feedback

Could you test again after uninstalling all plugins?

#2 Updated by Go MAEDA about 1 month ago

  • Status changed from Needs feedback to Closed
  • Resolution set to No feedback

Also available in: Atom PDF