Defect #30161

Incorrect supported Ruby version in doc/INSTALL

Added by Go MAEDA 9 months ago. Updated 7 months ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Jean-Philippe Lang% Done:

0%

Category:Documentation
Target version:4.0.1
Resolution:Fixed Affected version:4.0.0

Description

Redmine 4.0 (Rails 5.2) requires Ruby 2.2.2 or later, but doc/INSTALL states Ruby 2.2.1 or later.

Index: doc/INSTALL
===================================================================
--- doc/INSTALL    (revision 17702)
+++ doc/INSTALL    (working copy)
@@ -7,7 +7,7 @@

 == Requirements

-* Ruby >= 2.2.1
+* Ruby >= 2.2.2
 * RubyGems
 * Bundler >= 1.5.0

@@ -29,7 +29,7 @@
 2. Create an empty utf8 encoded database: "redmine" for example

 3. Configure the database parameters in config/database.yml
-   for the "production" environment (default database is MySQL and ruby1.9)
+   for the "production" environment (default database is MySQL)

 4. Install the required gems by running:
      bundle install --without development test


Related issues

Related to Redmine - Feature #25538: Drop support for Ruby 2.2.1 and ealier, 2.2.2+ is now req... Closed

Associated revisions

Revision 17815
Added by Jean-Philippe Lang 7 months ago

Incorrect supported Ruby version in doc/INSTALL (#30161).

Patch by Go MAEDA.

Revision 17816
Added by Jean-Philippe Lang 7 months ago

Merged r17815 to 4.0-stable (#30161).

History

#1 Updated by Go MAEDA 9 months ago

  • Affected version set to 4.0.0

#2 Updated by Go MAEDA 9 months ago

  • Related to Feature #25538: Drop support for Ruby 2.2.1 and ealier, 2.2.2+ is now required added

#3 Updated by Jean-Philippe Lang 9 months ago

ruby 2.2 is no longer maintained: https://www.ruby-lang.org/en/news/2018/06/20/support-of-ruby-2-2-has-ended/
Shouldn't we require ruby 2.3?

#4 Updated by Go MAEDA 9 months ago

Jean-Philippe Lang wrote:

ruby 2.2 is no longer maintained: https://www.ruby-lang.org/en/news/2018/06/20/support-of-ruby-2-2-has-ended/
Shouldn't we require ruby 2.3?

I am in favor of dropping support for Ruby 2.2. It is not very important to support 4 years old Ruby, I think. And it should be a good news for plugin developers.

#5 Updated by Go MAEDA 9 months ago

  • Assignee set to Jean-Philippe Lang

#6 Updated by Jean-Philippe Lang 7 months ago

  • Status changed from New to Closed
  • Resolution set to Fixed

Patch committed. We can't drop support for a ruby version in a minor version, so we keep 2.2 for now.

Also available in: Atom PDF