Patch #30163

Remove unnecessary tests in test/unit/initializers/patches_test.rb

Added by Go MAEDA 8 months ago. Updated 7 months ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Go MAEDA% Done:

0%

Category:Code cleanup/refactoring
Target version:4.1.0

Description

There are tests for ActiveSupport::HashWithIndifferentAccess in test/unit/initializers/patches_test.rb. Now we can remove those tests safely.

The tests were added in r13115 to test a patch that was added as a workaround for regression of Ruby 2.1. However, the patch was removed in r13892 so the tests lost its meaning. The tests should have been removed along with the patch but it is still there.

This patch deletes the tests which became unnecessary since r13892.

remove-unnecessary-tests.diff Magnifier (2.44 KB) Go MAEDA, 2018-12-09 17:37

Associated revisions

Revision 17727
Added by Go MAEDA 7 months ago

Remove unnecessary tests in test/unit/initializers/patches_test.rb (#30163).

Revision 17733
Added by Jean-Philippe Lang 7 months ago

Removed instance variables that are no longer used after r17727 (#30163).

History

#1 Updated by Go MAEDA 7 months ago

  • Status changed from New to Closed
  • Assignee set to Go MAEDA

Committed.

Also available in: Atom PDF