Defect #3132

Bulk editing menu non-functional in Opera browser

Added by Anonymous over 8 years ago. Updated over 6 years ago.

Status:ClosedStart date:2009-04-07
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:UI
Target version:1.1.2
Resolution:Fixed Affected version:

Description

In the Opera web browser it doesn't seem to work at all, it just brings up its default right-click menu.
This happens on both a local installation and on redmine.org

Version 10.00 alpha
Build 1139
Platform Win32
System Windows XP

I don't have the latest stable installed since I only use it for testing out my CSS, so I can't confirm whether this happens on version 9.5 or not. Just stumbled upon this by accident and figured you'd want to know.

context_menu_js.patch Magnifier (1006 Bytes) Claudio Acciaresi, 2010-12-22 16:11


Related issues

Duplicated by Redmine - Patch #7700: Enable right-click in Opera Closed 2011-02-23

Associated revisions

Revision 4935
Added by Jean-Philippe Lang over 6 years ago

Fixed: Bulk editing menu non-functional in Opera browser (#3132).

Contributed by Claudio Acciaresi.

History

#1 Updated by Anonymous over 8 years ago

  • Status changed from New to Resolved

I was just looking through the guide in the wiki and noticed:

A context menu pops up when right clicking (ALT + Left click for Opera users) on an issue of the issue list.

My bad, issue can be closed as I just tested to confirm it works ;)

#2 Updated by Jean-Philippe Lang over 8 years ago

  • Status changed from Resolved to Closed
  • Resolution set to Invalid

Thanks.

#3 Updated by Ammler _ over 8 years ago

  • Status changed from Closed to Reopened

I am using Opera 9.64 on linux and I am not able to use the context menu, either with right click or alt and left click. It works as it should with Firefox and Konqueror.

#4 Updated by Muntek Singh over 7 years ago

  • Affected version (unused) set to devel
  • Resolution deleted (Invalid)

I can confirm this - Testing in Linux and Windows. Every browser the right click context menu works except Opera.

Testing using opera 10.53 in windows
Testing using opera 10.53b1 in Linux

#5 Updated by André Jonsson about 7 years ago

Tested to be working on Opera 10.70 (3488) Windows 7 64.
I got mislead for a while that it was alt+rightclick... but it's, as stated above, Alt + left click.

#6 Updated by André Jonsson about 7 years ago

And 10.70 (something build) on Linux (32 bit) works as well.

#7 Updated by André Jonsson about 7 years ago

I think the right-click could be made to work.
I noticed that Zimbra has a working right-click menu, also in Opera.

#8 Updated by Claudio Acciaresi almost 7 years ago

Hi there, I'm attaching a patch that solves this problem (at least for opera versions > 10.53).
This a link was useful: http://unixpapa.com/js/mouse.html

Sorry if this is not the correct way to propose a patch to solve this issue, this is my first time contributing (I went trough the wiki but I did not find information on how I should prepare [name convention, etc] the patch) with redmine.

#9 Updated by Claudio Acciaresi almost 7 years ago

Claudio Acciaresi wrote:

Hi there, I'm attaching a patch that solves this problem (at least for opera versions > 10.53).
This a link was useful: http://unixpapa.com/js/mouse.html

Sorry if this is not the correct way to propose a patch to solve this issue, this is my first time contributing (I went trough the wiki but I did not find information on how I should prepare [name convention, etc] the patch) with redmine.

This solution applies to opera versions >= 10.53.

#10 Updated by Mischa The Evil almost 7 years ago

Claudio Acciaresi wrote:

  • File context_menu_js.patch added

Thanks for your contribution... I've tested your patch quickly using Opera 11.00 on Win (only) and it works as expected and does what it needs to do.

#11 Updated by Jean-Philippe Lang almost 7 years ago

Obviously, this patch breaks the ability to use ALT+Left click to show the context menu with Opera (versions before 10.0 don't support the 'contextmenu' event). Should we drop this in favor of right click for Opera >= 10.0 only ?

#12 Updated by Claudio Acciaresi almost 7 years ago

+1, I think that Opera version 10.53 is from April/May, so is pretty old.

I would drop the ALT+click functionality, is not as intuitive as using right click on the issue, and most Opera users tend to use the latest versions.

#13 Updated by André Jonsson almost 7 years ago

I agree, Opera users (including myself) are bleeding-edge kind of users... :)
Vote for dumping the old alt-click and adopting use of right-click.

A really advanced variant would be to detect the opera version and use right-click when available, otherwise alt-click. But I wouldn't recommend it; it's not worth the effort and the added complexity.

#14 Updated by Jean-Philippe Lang over 6 years ago

  • Category set to UI
  • Status changed from Reopened to Resolved
  • Target version set to 1.1.2
  • Resolution set to Fixed

Agreed. Patch applied in r4935, thanks.

#15 Updated by Pierre-Luc Samuel over 6 years ago

I just submitted patch #7700 (before noticing that this bug existed, DOH). I think my patch is a bit more thorough, since it also restores the normal Single-click behavior. Sorry for the duplication...

#16 Updated by Jean-Philippe Lang over 6 years ago

  • Status changed from Resolved to Closed

Merged in 1.1-stable.

Also available in: Atom PDF