Defect #31510

Fix missing closing tags in workflows/permissions.html.erb

Added by Enziin System 6 months ago. Updated 5 months ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Go MAEDA% Done:

0%

Category:Code cleanup/refactoring
Target version:4.1.0
Resolution:Fixed Affected version:

Description

In the view/workflows/permissions.html.erb

Row 19:

<a href="#" data-expands="#role_id"><span class="toggle-multiselect icon-only icon-toggle-plus"></a>

Row 24:

<a href="#" data-expands="#tracker_id"><span class="toggle-multiselect icon-only icon-toggle-plus"></a>

Missing close tag for span.

Please use an editor support check syntax (ex: Rubymine)


Related issues

Related to Redmine - Patch #21256: Use CSS instead of image_tag() to show icons for better t... Closed

Associated revisions

Revision 18323
Added by Go MAEDA 5 months ago

Fix missing closing tags in workflows/permissions.html.erb (#31510).

Contributed by Enziin System.

History

#1 Updated by Marius BALTEANU 6 months ago

  • Category changed from UI to Code cleanup/refactoring
  • Status changed from New to Confirmed

Enziin System wrote:

In the view/workflows/permissions.html.erb

Row 19:

<a href="#" data-expands="#role_id"><span class="toggle-multiselect icon-only icon-toggle-plus"></a>

Row 24:

<a href="#" data-expands="#tracker_id"><span class="toggle-multiselect icon-only icon-toggle-plus"></a>

Missing close tag for span.

Thanks for finding this issue, it seems to be an old problem introduced by r15068.

Please use an editor support check syntax (ex: Rubymine)

Please believe me that I’m doing my best.

#2 Updated by Go MAEDA 6 months ago

  • Related to Patch #21256: Use CSS instead of image_tag() to show icons for better theming support added

#3 Updated by Go MAEDA 5 months ago

  • Subject changed from Error syntax in workflows/permissions.html.erb to Fix missing closing tags in workflows/permissions.html.erb
  • Status changed from Confirmed to Closed
  • Assignee set to Go MAEDA
  • Target version set to 4.1.0
  • Resolution set to Fixed

Committed the fix. Thank you for reporting this issue.

Also available in: Atom PDF