Patch #31899

Improve MailHandler logging for unauthorized attempts

Added by Gustavo Regal about 1 month ago. Updated 22 days ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Go MAEDA% Done:

0%

Category:Email receiving
Target version:4.1.0

Description

I usually struggle to understand the root cause when one e-mail fails tu be processed.
What I do in those situations is to read production.log and search for "MailHandler:" entries.
It is not unusual to find only one entry, saying:

MailHandler: Message <id> cannot be processed

So I started this improvement, which already allowed to find out that, in a given case, the issue could not be created because the user didn't have permission to create it under that given project. In fact, the user had sent an e-mail to the wrong recipient (missed the sub-address).

MailLogger_cause_logging_improvement.diff Magnifier (1.61 KB) Gustavo Regal, 2019-08-14 16:23

31899-v2.patch Magnifier (1.75 KB) Go MAEDA, 2019-08-27 09:21

Associated revisions

Revision 18404
Added by Go MAEDA 22 days ago

Improve MailHandler logging for unauthorized attempts (#31899).

Patch by Gustavo Regal.

History

#1 Updated by Go MAEDA about 1 month ago

  • Target version set to 4.1.0

LGTM. Setting the target version to 4.1.0.

#2 Updated by Go MAEDA 23 days ago

Slightly updated the patch.

#3 Updated by Go MAEDA 23 days ago

  • Subject changed from Improve MailHandler logging to Improve MailHandler logging for unauthorized attempts

#4 Updated by Go MAEDA 22 days ago

  • Status changed from New to Closed
  • Assignee set to Go MAEDA

Committed the patch. Thank you for improving Redmine.

Also available in: Atom PDF