Patch #32297

Remove code for unsupported versions of Rails from open_id_authentication

Added by Go MAEDA about 1 month ago. Updated 28 days ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Go MAEDA% Done:

0%

Category:Code cleanup/refactoring
Target version:4.1.0

Description

Redmine migrated to Rails 3 in Redmine 2.0 (released in 2012). We no longer support such older versions of Rails, so we can remove the code for Rails less than 3.0.

Index: lib/plugins/open_id_authentication/init.rb
===================================================================
--- lib/plugins/open_id_authentication/init.rb    (リビジョン 18732)
+++ lib/plugins/open_id_authentication/init.rb    (作業コピー)
@@ -1,9 +1,5 @@
 # frozen_string_literal: false

-if Rails.version < '3'
-  config.gem 'rack-openid', :lib => 'rack/openid', :version => '>=0.2.1'
-end
-
 require 'open_id_authentication'

 config.middleware.use OpenIdAuthentication

Associated revisions

Revision 18788
Added by Go MAEDA 28 days ago

Remove code for unsupported versions of Rails from open_id_authentication (#32297).

Patch by Go MAEDA.

History

#1 Updated by Go MAEDA 29 days ago

  • Subject changed from Remove the code for Rails less than 3.0 in lib/plugins/open_id_authentication/init.rb to Remove the code for Rails earlier than 3.0 in lib/plugins/open_id_authentication/init.rb
  • Target version changed from Candidate for next minor release to 4.1.0

Setting the target version to 4.1.0.

#2 Updated by Go MAEDA 28 days ago

  • Subject changed from Remove the code for Rails earlier than 3.0 in lib/plugins/open_id_authentication/init.rb to Remove code for unsupported versions of Rails from open_id_authentication
  • Status changed from New to Closed
  • Assignee set to Go MAEDA

Committed.

Also available in: Atom PDF