Defect #3268

browsing subversion repo fails under apache, but works under WEBrick

Added by Roy Marples over 8 years ago. Updated about 8 years ago.

Status:ClosedStart date:2009-04-30
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:SCM
Target version:0.8.5
Resolution:Fixed Affected version:0.8.3

Description

The happens when browsing subversion directories in the repo - showing the root works as does going sraight to a file, viewing it, comparing, etc.

Crash log attached.

I'm stumped for ideas as to why this should be.
The server in question runs NetBSD-5.0 and all the required rails foo from pkgsrc HEAD.

production.log (4.12 KB) Roy Marples, 2009-04-30 01:18

Associated revisions

Revision 2722
Added by Jean-Philippe Lang over 8 years ago

Prevent nil error when retrieving svn version (#3268).

History

#1 Updated by Jean-Philippe Lang over 8 years ago

  • Status changed from New to Resolved

Apache is not the problem. This website runs with Apache and SVN browsing works just fine.
I don't know why but the svn --version command seems to fail. I've committed a fix in r2722 that should prevent this error from being raised.
Can you confim please?

#2 Updated by Roy Marples over 8 years ago

Confirmed fix.
Thanks!

#3 Updated by Eric Davis over 8 years ago

  • Target version set to 0.8.5
  • Resolution set to Fixed

Should be merged into 0.8.x stable branch.

#4 Updated by Jean-Philippe Lang about 8 years ago

  • Status changed from Resolved to Closed

Merged in 0.8-stable in r2883.

Also available in: Atom PDF