Defect #3289

E-mail in /user/edit/N displayed (and saves) as administrating users login-name

Added by Kai Olav Fredriksen over 10 years ago. Updated over 3 years ago.

Status:ClosedStart date:2009-05-04
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Administration
Target version:-
Resolution:Cant reproduce Affected version:0.8.3

Description

We have a 0.8.3 stable installation going. When I go in to administate a user (/users/edit/<Number>) (I'm on my account - not Redmine Admin) - the e-mail field changes to my login-name.

screenshot-403.png (36.1 KB) Go MAEDA, 2016-01-20 07:36

History

#1 Updated by Jean-Philippe Lang over 10 years ago

Not able to reproduce this problem.
Do you have some details that would help to reproduce?

#2 Updated by Kai Olav Fredriksen over 10 years ago

Jean-Philippe Lang wrote:

Not able to reproduce this problem.
Do you have some details that would help to reproduce?

We're running "Redmine 0.8.3.stable (SQLite)" - I'm using it through Google Chrome on WinXP - I'm not sure what you need in order to reproduce, I will try it out a bit today, and try give a proper answer to you if I find anything that can help.

#3 Updated by Kai Olav Fredriksen over 10 years ago

Jean-Philippe Lang wrote:

Not able to reproduce this problem.
Do you have some details that would help to reproduce?

Ok - it's Google Chrome. OK when using IE. What happens is more than I reported. This is a very shallow observation: Administration->Users->Select user...: Fields labeled "Email" and "Password" turns yellow background. Email-field holds MY login-name, and "Password" holds dots (the "Confirmation"-field is normal, no dots - making it impossible to change user-details without setting password.)

I used Chrome a good year ago when I installed Redmine on my previous job, without any problem - but it's not good to say what has changed, Chrome or Redmine.

#4 Updated by Kai Olav Fredriksen over 10 years ago

Kai Olav Fredriksen wrote:

Jean-Philippe Lang wrote:

Not able to reproduce this problem.
Do you have some details that would help to reproduce?

Ok - it's Google Chrome. OK when using IE. What happens is more than I reported. This is a very shallow observation: Administration->Users->Select user...: Fields labeled "Email" and "Password" turns yellow background. Email-field holds MY login-name, and "Password" holds dots (the "Confirmation"-field is normal, no dots - making it impossible to change user-details without setting password.)

I used Chrome a good year ago when I installed Redmine on my previous job, without any problem - but it's not good to say what has changed, Chrome or Redmine.

Not "a good year ago" of course; "last year" that is

#5 Updated by Go MAEDA over 3 years ago

  • Status changed from New to Closed
  • Resolution set to Cant reproduce

I am closing this issue. Please reopen if the problem persists on the current versions of Redmine.

#6 Updated by Go MAEDA over 3 years ago

Non admin users cannot see /users/1/edit.

Also available in: Atom PDF