Defect #3298

When updating an issue, clicking a link destroys all my input

Added by Sam Goldstein over 8 years ago. Updated about 8 years ago.

Status:ClosedStart date:2009-05-05
Priority:HighDue date:
Assignee:-% Done:

0%

Category:-
Target version:-
Resolution:Duplicate Affected version:0.8.1

Description

This occasionally drives me crazy.

When updating an issue I type a detailed comment in the textarea. I need to check something so I click a link to an attached file or another ticket. Since the update form is loaded through an AJAX request hitting back in my browser means that all of my input is destroyed (and not preserved by the browser).

It would be great if there was some mechanism in place to prevent dummies like me from doing this repeatedly. Perhaps a Gmail style, "You've edit this page, are you sure you want to leave it" JS, or loading the update form through a conventional (non-Ajax) request, so that browsers preserve the form fields.

Thanks for the great system.


Related issues

Duplicates Redmine - Feature #2910: Warning on leaving edited issue/wiki page without saving Closed 2009-03-05

History

#1 Updated by Thomas Pihl over 8 years ago

Shouldnt really be a defect, should it? It works as intended. If you think it should be enhanced i´d guess it should be a feature request.

/T

#2 Updated by Jean-Philippe Lang about 8 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

See #2910.

Also available in: Atom PDF