Feature #3485

Closed statuses in dropdown for new issue (manager role)

Added by Barbara Post over 8 years ago. Updated over 1 year ago.

Status:ClosedStart date:2009-06-12
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Issues
Target version:-
Resolution:Duplicate

Description

The following applies to manager role when creating a new issue.

I find illogical to have closed and rejected statuses in the "new issue" status dropdown. As they are marked as "closed issue" in admin panel, I think they should be filtered, and any to be created issue would then only propose "new" or "assigned" status in the dropdown.

May I have some wrong settings ? I feel like the proposed states are the ones which can lead to "new" state, without checking whether they are closed states or not :)

I attach the manager's bug issue worklow.

The rapporter only has "new" option, while the developer has "new" and "assigned".

PS : when creating this redmine issue, I see "status" having both "new" and "resolved" options...

wf_1.png - manager's bug issue workflow (18.1 KB) Barbara Post, 2009-06-12 09:26


Related issues

Duplicates Redmine - Feature #5816: New issue initial status should be settable in workflow Closed 2010-07-05

History

#1 Updated by Thomas Pihl over 8 years ago

Well, i think you have a point. But then again, i do sometimes enter issues that is already done (i just enter them for reference). In that case it would be double-work to first enter it into an open state and then change it to a closed state.

Some my customers raised same question. When they got slightly more used to redmine, the problem went away. Now they understand that they see every status they are ALLOWED to use, and have to choose.

/T

#2 Updated by Mischa The Evil over 8 years ago

Thomas Pihl wrote:

[...] But then again, i do sometimes enter issues that is already done (i just enter them for reference). In that case it would be double-work to first enter it into an open state and then change it to a closed state.

I feel the same way about this...

#3 Updated by Mischa The Evil over 8 years ago

  • Tracker changed from Defect to Feature

#4 Updated by Ewan Makepeace over 8 years ago

I often add closed tasks to redmine to credit the developer concerned for urgent work that I had asked him to do verbally.

#5 Updated by Dipan Mehta over 4 years ago

Ideally a 'New issue' can go to any other status as defined by the workflow. However, it is desirable that when the issue is registered it must first attain the default status (typically New) at least once! It breaks many workflow assumptions.

When a new ticket is being opened, status should not be changeable. It should be changeable only during the update.

#6 Updated by Go MAEDA over 1 year ago

  • Duplicates Feature #5816: New issue initial status should be settable in workflow added

#7 Updated by Go MAEDA over 1 year ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

This issue has been resolved by #5816 (Redmine 3.2.0).
Now we can limit statuses for a new issue by workflow settings.

Also available in: Atom PDF