Defect #3494

Browser "Back" to issue list displays wrong filter

Added by Roman Starkov over 9 years ago. Updated almost 6 years ago.

Status:ClosedStart date:2009-06-13
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:UI
Target version:-
Resolution:Cant reproduce Affected version:

Description

Reproducible on this website using Firefox 3.0.10.

1. Go to Issues.
2. Add a few filter clauses.
3. Click an issue to view it
4. Click Back in the browser.

Actual: the Issues list is shown with all filter customization lost.

Expected: all filter changes preserved when going Back.

Further info: it is possible to make the settings stick as follows:

Steps 1-3 as before
4. Click the "Issues" tab
5. Click an issue to view it
6. Click Back in the browser

This way step 6 shows the correct filter.


Related issues

Related to Redmine - Defect #1965: Redmine is not Tab Safe Closed 2008-09-29
Related to Redmine - Defect #657: Back button - loses current page after viewing an issue -... Closed 2008-02-13
Related to Redmine - Patch #7594: Proper pagination Closed 2011-02-09

History

#1 Updated by Eric Davis over 9 years ago

  • Resolution set to Cant reproduce

Worked for me (Firefox 3). After clicking back in your first scenario, my filters were saved. Could this be a browser caching issue instead of a Redmine issue?

#2 Updated by Roman Starkov over 9 years ago

  • Status changed from New to Resolved

Indeed, not reproducible for me in Firefox 3.5 either. Thanks.

#3 Updated by Eric Davis over 9 years ago

  • Status changed from Resolved to Closed

Thanks for the feedback. Let us know if anything else comes up.

#4 Updated by Artem K. about 9 years ago

exactly the same problem.
Firefox 3.5
couldn't find how to setup this browser to do not cache the Redmine site

#5 Updated by Artem K. about 9 years ago

  • Status changed from Closed to Reopened

another one similar issue: cannot return back from issue to that page of issue list from wich this issue was opend.

Example:
1. Filter issues
2. Click "Next" or "2"
3. Click an issue to view it
4. Click Back in the browser OR "Issues" tab

Actual: the page 1 of Issues list is shown.
Expected: the page 2 with viewed issue to be shown.

May be it is possible to make some simple links on issue view like "next/prev issue", "return to list" for navigation in bounds of that filtered list from wich the showed issue was open

#6 Updated by Anonymous over 8 years ago

I still get this with Redmine 0.9.5 using Chrome (6.0.453.1 dev, Mac OS X). Behavior will probably be similar with other WebKit-based browsers such as Safari.

In general this bug is going to occur if the browser decides not to restore a freeze-dried page state when going back to the search page. If the page state gets regenerated from HTML it's going to come up with the original search/page settings again. Whether or not this happens is basically an implementation detail of the browser. Some are more aggressive about preserving page state than others, and it may also depend on the depth of the back list and on available memory. You can't depend on it.

#7 Updated by Henrik Ammer over 8 years ago

Jens Alfke wrote:

I still get this with Redmine 0.9.5 using Chrome (6.0.453.1 dev, Mac OS X). Behavior will probably be similar with other WebKit-based browsers such as Safari.

I've seen this bug since I first started using Redmine on Windows and Firefox 3.5+. And my cache setting is get most recent on every request so it ain't a cache problem in the browser. Personally I agree with the conclusion of Jens regarding the preservation of the page.

#8 Updated by Brad Erickson about 8 years ago

This error is consistently reproducible in Google Chrome: 6.0.472.62 (Official Build 59676) beta. I only open issues in tabs to avoid it.

#9 Updated by Brian Lindahl almost 8 years ago

related to #1965

#10 Updated by Brian Lindahl almost 8 years ago

related to #5138

#11 Updated by Brian Lindahl almost 8 years ago

related to #657

#12 Updated by Brian Lindahl almost 8 years ago

In #7594, I've created a patch to temporarily solve this problem until a real solution exists. It disables Ajax updates and uses direct linking for pagination.

#13 Updated by Anonymous over 7 years ago

HTML5 history modification (pushState and friends) can probably alleviate this in newer browsers: https://developer.mozilla.org/en/DOM/Manipulating_the_browser_history#Adding_and_modifying_history_entries

See https://github.com/defunkt/jquery-pjax for an example library GitHub uses; browse around the file tree (in Firefox 4 or recent Chrome) to see it in action.

#14 Updated by Ivan Cenov almost 6 years ago

Tested in our production Redmine 2.2.3:
Can't reproduce: after pressing Back button the issue list has the filter that has been set before opening an issue.

#15 Updated by Daniel Felix almost 6 years ago

  • Status changed from Reopened to Closed

I'm closing this issue as this one is very old and the named browser is fairly outdated. If you can confirm this behavior in current releases with current browsers please reopen this issue again. Thanks.

Thanks Ivan for this hint.

Also available in: Atom PDF