Defect #3496

"Assign To" filter on "View all issues" page allows to select user which cannot be assigned

Added by Markus Knittig over 10 years ago. Updated over 6 years ago.

Status:ClosedStart date:2009-06-14
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:-
Resolution:Cant reproduce Affected version:

Description

Steps to reproduce:
  • Go to "Projects"
  • Click on "View all issues"
  • Add "Assign To" filter
  • All registered users are shown, even if they have a role which cannot be assigned to issues.

History

#1 Updated by Jean-Philippe Lang over 10 years ago

Unable to reproduce. On the cross-project issue list, users who belongs to the current user's projects are shown, not all registered users.

#2 Updated by Markus Knittig over 10 years ago

Jean-Philippe Lang wrote:

Unable to reproduce. On the cross-project issue list, users who belongs to the current user's projects are shown, not all registered users.

Your right, but a user who cannot be assigned to an issue should still not be shown in the "Assign To" filter. That makes no sense...

#3 Updated by Felix Dominguez over 10 years ago

I was able to reproduce with revision 2791 of the trunk.
I'm looking into it.

#4 Updated by Anonymous over 6 years ago

I cannot reproduce this in Redmine 2.2.3. First off, there is no "Assign To" filter. So I'll assume that this was an older name for "Assignee". I added a new test user to my tracker who is not a member of any project. It was then not possible to select that user in the "Assignee" field.

#5 Updated by Daniel Felix over 6 years ago

  • Status changed from New to Closed
  • Resolution set to Cant reproduce

I'm also not able to reproduce this.

Please reopen this issue if this is still reproduce able in the current releases.

Also available in: Atom PDF