Defect #3583

Lack of element + clear at the base of the views causes some themes to display oddly in Firefox

Added by Chris McKee over 8 years ago. Updated over 4 years ago.

Status:ClosedStart date:2009-07-03
Priority:LowDue date:
Assignee:-% Done:

0%

Category:UIEstimated time:0.50 hour
Target version:-
Resolution:Duplicate Affected version:0.8.3

Description

Pages that are made larger than 600px heigh by their content display oddly (overflow)

  • IE6 (windows xp)
  • Firefox 2 / 3/ 3.5 (windows)
  • Displays correctly in Safari (win) and Chrome (webkit)

Basically a float overflow bug; but as theirs no element at the base of the views to clear you cant fix it without editing the view.

The inclusion of <p style="clear:both"> </p> at the base of these views fixes the issue. as per attached sample view.

app.views.welcome.index.rhtml Magnifier - Sample View (1.32 KB) Chris McKee, 2009-07-03 18:13


Related issues

Related to Redmine - Patch #3053: Patch for layout/base.rthml Closed 2009-03-26
Duplicates Redmine - Defect #3438: MyPage CSS display issue: white background is not high en... Closed 2009-06-02 2013-02-13

History

#1 Updated by Chris McKee over 8 years ago

Attachment didn't attach

#2 Updated by J Cayetano Delgado over 8 years ago

related to: #3438

and maybe to: #3053

#3 Updated by Chris McKee about 8 years ago

duplicates: #3438 though the sample code in that issue is "ok" but wrong ;o)

#4 Updated by Daniel Felix over 4 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

Indeed, this seems to be a duplicate of #3438.

Also available in: Atom PDF