Feature #3751

Associate Revisions with Issues afterwards

Added by Magnus Bergmark about 8 years ago. Updated about 8 years ago.

Status:ClosedStart date:2009-08-18
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Issues
Target version:-
Resolution:Duplicate

Description

Proposal:

When browsing a Revision, add an interface element for associating selected Revision with one or more Issues. When looking at an Issue, have an interface element for associating Revisions with the Issue.

Motivation:

In some cases, a developer might forget to add a proper ref #nnn inside the commit message, spell the trigger word wrong, entering wrong Issue number or perhaps even just forget that the Revision actually was associated with an existing Issue. It would be useful for historical purposes to be able to modify this relationship outside of committing.

It seems to be pretty trivial to create from a Model standpoint, since all the infrastructure is already there. I think that the UI and controller actions is what should be most non-trivial to implement.


Related issues

Duplicates Redmine - Feature #2009: Manually add related revisions Closed 2008-10-08

History

#1 Updated by Mischa The Evil about 8 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

Closed as a duplicate of issue #2009.

Also available in: Atom PDF