Defect #3778

Non-administrator users cannot set parent project for new projects

Added by Gábor Molnár over 8 years ago. Updated over 8 years ago.

Status:ClosedStart date:2009-08-25
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:-
Resolution:Duplicate Affected version:

Description

It is not possible for non-administrator users to set the parent of the project to be created. There is no parent project field on the new project page, even if i am the owner of the project that i want to set as parent. There is no such option even in the settings page of an existing project.

I am using the svn trunk version.

003-redmine-admin-project.diff Magnifier (570 Bytes) Patrice Bonhomme, 2009-08-31 18:00


Related issues

Duplicates Redmine - Feature #2963: Managers able to create subprojects Closed 2009-03-13

History

#1 Updated by Patrice Bonhomme over 8 years ago

In the file app/views/projects/_form.rhtml, change the line :

<% if User.current.admin? && _parents.empty? %>

With :

<% if _parents.empty? %>

This is what i have done and it works.

#2 Updated by Patrice Bonhomme over 8 years ago

Arghhhhh !!!!

In the file app/views/projects/_form.rhtml, change the line :
<% if User.current.admin? && _parents.empty? %>

With :
<% if _parents.empty? %>

This is what i have done and it works.

#3 Updated by Eric Davis over 8 years ago

  • Status changed from Resolved to Closed
  • Resolution set to Duplicate

This is a duplicate of #2963

Also available in: Atom PDF