Feature #3808

Provide link to actual SCM URL from repository page

Added by CS Wong about 10 years ago. Updated almost 9 years ago.

Status:ClosedStart date:2009-09-02
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:SCM
Target version:-
Resolution:Duplicate

Description

Note: I'm not sure if this is possible with SCMs other than Subversion 'cos I don't really have much experience with other SCMs.

While browsing the repository, it'd be nice if I can get a direct link to the file in question from the Repository page.

For e.g., assume my SVN repo is at http://svn.me.com/myproject/trunk/

When, browsing the repo, the entry "/src" would have a link on its line that links directly to http://svn.me.com/myproject/trunk/src/.

As it is, when I spot something I want to checkout, I need to figure out the path to the repo and there's nowhere for me to copy and paste the root path of the repo either if I don't have admin access.


Related issues

Duplicates Redmine - Patch #232: SCM URL/ROOT Information on Repository Page New

History

#1 Updated by Holger Just over 9 years ago

Duplicate of #232

#2 Updated by Holger Just almost 9 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

Also available in: Atom PDF