Defect #4146

Textile formatting does not work

Added by Andrew Kouznetsov about 10 years ago. Updated almost 9 years ago.

Status:ClosedStart date:2009-11-02
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Text formatting
Target version:-
Resolution:Invalid Affected version:

Description

I have just installed redmine from trunk and created a project with description "*SaaS foo bar*"
At the project page i see deescription SaaS foo bar but textile option is enabled.

textile.png (26.3 KB) Yasuo Yokoyama, 2009-11-19 10:07

History

#1 Updated by Jean-Philippe Lang about 10 years ago

  • Status changed from New to Closed
  • Resolution set to Invalid

Your bug report is unclear.
If textile is enabled, it will be displayed in bold.

#2 Updated by Andrew Kouznetsov about 10 years ago

  • Status changed from Closed to Reopened

Sorry. I wanted to say that I see stars as is, not bold text.

#3 Updated by Jean-Philippe Lang about 10 years ago

Also, did you want to say that the problem is on the projects list, not on the project page?

#4 Updated by Andrew Kouznetsov about 10 years ago

No, the problem is on the project page and on the project list.
It is here: http://redmine.goldcontrol.ru/projects/motivator

#5 Updated by Jean-Philippe Lang about 10 years ago

Sorry, I can't reproduce.
The exact same text is displayed in bold with a fresh checkout and textile enabled.

#6 Updated by Felix Schäfer about 10 years ago

Andrew, pelase make sure the option "Text formatting" in Administration > Settings > General is set to "textile". Setting it to "none" was the only way I was able to reproduce your error.

#7 Updated by Andrew Kouznetsov about 10 years ago

This option is set to "textile".
Revision number is 2993.
You can see admin interface - login SMiX, password admin

#8 Updated by Felix Schäfer about 10 years ago

I've had a look at your installation, and you should complete the installation properly, by giving the webserver or the rails process the correct rights on the correct folders (have a look at http://redmine.goldcontrol.ru/admin/info ). I doubt that will correct your textile problem though.

As to the textile problem: only +, -, * and _ are ignored, everything else like hX. tags and @ are rendered correctly. Might it be that the Regexes defined in source:trunk/lib/redcloth3.rb#L364 and following are somehow sensitive to whatever encoding his server is running in?

Andrew, could you possibly tell us what the locales are for the user your rails processes are running as?

#9 Updated by Andrew Kouznetsov about 10 years ago

Now i have completed the installation properly but the problem already exists.
Rails are running by user redmine. Locale is ru_RU.UTF-8.
Also, sorry for my english :) Thanks.

#10 Updated by Fedor Shubin about 10 years ago

Hi,Andrew. But "*SaaS-проект для мотивации сотрудников компании*." (dot-ending) is working )).
In my 0.8.4.stable version there is no this problem.

#11 Updated by Felix Schäfer about 10 years ago

As I said, the problem is not a "generic" installation, his description string works fine in my dev redmine, even without the trailing dot.

I've created a wiki page on Andrew's Redmine install to show my point: http://redmine.goldcontrol.ru/projects/motivator/wiki/Foo. I've made a line for each tag that came to mind: some work, some doesn't. I've put the different tags used at the bottom in @s for reference.

#12 Updated by Yasuo Yokoyama about 10 years ago

I have a same problem on recent trunk.

Redmine 0.8.7.devel.3076 (PostgreSQL)

# ruby -v
ruby 1.8.7 (2009-04-08 patchlevel 160) [amd64-freebsd8]
# gem list -local
actionmailer (2.3.4)
actionpack (2.3.4)
activerecord (2.3.4)
activeresource (2.3.4)
activesupport (2.3.4)
fastthread (1.0.7)
mocha (0.9.7)
nofxx-object_daddy (0.4.1)
passenger (2.2.5)
postgres (0.7.9.2008.01.28)
rack (1.0.0)
rails (2.3.4)
rake (0.8.7)
sources (0.0.2)
sqlite3-ruby (1.2.4)
thoughtbot-shoulda (2.10.2)

An attached image is a result of doing preview.

#13 Updated by Babar O'Cap almost 10 years ago

Fedor Shubin wrote:

Hi,Andrew. But "*SaaS-проект для мотивации сотрудников компании*." (dot-ending) is working )).
In my 0.8.4.stable version there is no this problem.

Same problem for me, with JRuby, see my Issue #3764

#14 Updated by Jean-Philippe Lang over 9 years ago

Yasuo Yokoyama wrote:

I have a same problem on recent trunk.

Redmine 0.8.7.devel.3076 (PostgreSQL)
[...]

An attached image is a result of doing preview.

I don't have this problem here. The following:

Test

*Test*

*Test* Test

Test *Test*

Test *Test* Test

Gives:

Test

Test

Test Test

Test Test

Test Test Test

#15 Updated by Mischa The Evil almost 9 years ago

  • Status changed from Reopened to Closed

Not able to reproduce on recent trunk. The expected result is rendered. Please re-open if this issue still persists on trunk.

Also available in: Atom PDF